听说你很厉害,来试试这个...

in 编程
关注公众号【好便宜】( ID:haopianyi222 ),领红包啦~
阿里云,国内最大的云服务商,注册就送数千元优惠券:https://t.cn/AiQe5A0g
腾讯云,良心云,价格优惠: https://t.cn/AieHwwKl
搬瓦工,CN2 GIA 优质线路,搭梯子、海外建站推荐: https://t.cn/AieHwfX9

刚在看开源中国动弹的时候,发现了这样的一条记录
file

很好奇这里提到的#文言#是什么项目,虽然程序员都是 直肠子, 但是这也太直白了一点。然后就点开了,这一点好像发现了新世界。

文言 项目是什么

文言(wenyan-lang)是一门采用文言文输入的编程语言,该语言不包括英文字符,仅包含繁体中文字符,并保留繁体引号「」。

file

简单点来说,就是使用文言文来编程。听说你很厉害,那来看看项目主页上面的序言部分

夫唐、虞之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械之巧,精於公輸之木鳶,善於武侯之流馬;程式語言之多,繁若《天官》之星宿,奇勝《山經》之走獸。鼠、蟹、鑽、魚,或以速稱。蛇、象、駱、犀,各爭文采。方知鬼之所以夜哭,天之所以雨粟。
然以文言編程者 ,似所未有。此誠非文脈之所以傳,文心之所以保。嗟予小子,遂有斯志。然則數寸之烏絲猶覆於頭,萬卷之素書未破於手;一身長羁于远邦,兩耳久旷于雅言。然夫文章者吾之所宿好,程式者偶承時人之謬譽。故希孟不慚年少,莊生不望無涯。乃作斯言。
誠未能嘔瀝長吉之心血,亦庶幾免於義山之流沫。既成之後,復學干將鑄劍而自飼,越王嚐糞而當先。
自謂偶追《十書》之筆意,但恨少八家之淋漓。此子山所謂士衡抚掌而甘心,平子見陋而固宜。
然則雖實覆甕之質,尚存斧正之望;雖乏呂相之金,易字之渴蓋同。此亦開源之大義,吾輩之所以勉勵也。一笑。

file

看看这介绍,从文字历史说起、再说明了这么做的初衷、然后作者自谦了一把,最后还是不忘请大家来一起参与。

Helloworld

程序员对 Helloworld 有特殊的感情,还是从这里开始。

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
	吾有一言。曰「「問天地好在。」」。書之。
云云。

编译成 JavaScript

var n = 3;
for (var i = 0; i < n; i++) {
	console.log("問天地好在。");
}

然后输出

問天地好在。
問天地好在。
問天地好在。

作者还好意提醒道:标点符号和换行完全是可选的(就像他们在中国古典),所以上面的代码就相当于:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云

看看作者这专业程度。

语法定义

变量

控制

运算

容器

函数

提供的功能

依照官网的介绍,具有下面的特性:

Online IDE

作者还提供了Online IDE :http://wenyan-lang.lingdong.works/ide.html

画风是这样的
filefile

其它信息

作品第一次提交 2019 年 10 月 9 日
file

在最大的同性交友平台上收获了 4.4 K 的 star, 看来还是很受欢迎的.
4.4 K 的 star


感兴趣的朋友,可以去试试看。
不说了,我去学习新语言了。

本文由博客一文多发平台 OpenWrite 发布!

关注公众号【好便宜】( ID:haopianyi222 ),领红包啦~
阿里云,国内最大的云服务商,注册就送数千元优惠券:https://t.cn/AiQe5A0g
腾讯云,良心云,价格优惠: https://t.cn/AieHwwKl
搬瓦工,CN2 GIA 优质线路,搭梯子、海外建站推荐: https://t.cn/AieHwfX9
扫一扫关注公众号添加购物返利助手,领红包
Comments are closed.

推荐使用阿里云服务器

超多优惠券

服务器最低一折,一年不到100!

朕已阅去看看