apt-get 安装失败问题

in 编程
关注公众号【好便宜】( ID:haopianyi222 ),领红包啦~
阿里云,国内最大的云服务商,注册就送数千元优惠券:https://t.cn/AiQe5A0g
腾讯云,良心云,价格优惠: https://t.cn/AieHwwKl
搬瓦工,CN2 GIA 优质线路,搭梯子、海外建站推荐: https://t.cn/AieHwfX9

今天在安装一个包时出现错误

sudo apt-get install libmapnik

从提示看不出来问题原因
clipboard.png

于是就按照提示apt-get -f install了一把,还是报错,应该是安装nodejs-dev时会覆盖nodejs-legacy的某个包,导致安装失败

clipboard.png

百度了半天没搞明白nodejs-legacy和nodejs的区别,于是强制安装了一把,

sudo dpkg -i --force-overwrite  /var/cache/apt/archives/nodejs_0.10.28-1chl1~trusty1_amd64.deb

仍然失败,于是安装了一把rlwrap,安装成功了

clipboard.png

然后再来安装就成功了

sudo apt-get install libmapnik

dpkg -i --force-overwrite、apt-get -f install 是解决安装冲突问题的两大利器

关注公众号【好便宜】( ID:haopianyi222 ),领红包啦~
阿里云,国内最大的云服务商,注册就送数千元优惠券:https://t.cn/AiQe5A0g
腾讯云,良心云,价格优惠: https://t.cn/AieHwwKl
搬瓦工,CN2 GIA 优质线路,搭梯子、海外建站推荐: https://t.cn/AieHwfX9
扫一扫关注公众号添加购物返利助手,领红包
Comments are closed.

推荐使用阿里云服务器

超多优惠券

服务器最低一折,一年不到100!

朕已阅去看看