CentOS7 编译安装nodejs,配置环境变量记录

in 编程
关注公众号【好便宜】( ID:haopianyi222 ),领红包啦~
阿里云,国内最大的云服务商,注册就送数千元优惠券:https://t.cn/AiQe5A0g
腾讯云,良心云,价格优惠: https://t.cn/AieHwwKl
搬瓦工,CN2 GIA 优质线路,搭梯子、海外建站推荐: https://t.cn/AieHwfX9

每次都装,每次都查

阿里云备案了一个域名,续费了好多年,但是没钱买服务器,就挂在github上。今天收到消息:域名解析服务器不在阿里云,要被GG。只能咬牙买了个阿里云乞丐版。

所有服务都装好了,ping域名也通了,就是无法访问。感谢伟大的sf网友,给我指明了方向
阿里云也不给个醒目的提示,让我等小白如何知道还要配置安全组。。。

安装nodejs

去nodejs官网查看需要的版本。官网

nodejs的安装需要依赖很多,如gcc等,首先我们需要将这些安装成功,用rpm命令rpm -q gcc查看下,如果没有gcc等,所以要用yum进行安装:

yum -y install gcc gcc-c++ kernel-devel

也可以使用下面命令查看否有 Development Tools

yum group list

没有的安装开发工具:

yum -y update && yum -y group install"Development Tools"

将依赖安装后,就可以进行nodejs安装啦
Linux目录介绍
Linux系统目录详解
linux下编译安装程序的路径说明

/home 用户主目录的基点,比如用户user的主目录就是/home/user,可以用~user表示
/var 某些大文件的溢出区,比方说各种服务的日志文件
/usr 最庞大的目录,要用到的应用程序和文件几乎都在这个目录。其中包含:
/usr/local 这里主要存放那些手动安装的软件,即不是通过“新立得”或apt-get安装的软件。它和/usr目录具有相类似的目录结构。让软件包管理器来管理/usr目录,而把自定义的脚本(scripts)放到/usr/local目录下面,我想这应该是个不错的主意。

我们就选/usr/local目录下新建一个nodejs目录来编译安装吧:
首先在~下新建一个download目录,去淘宝镜像查询可用版本,然后:

wget https://npm.taobao.org/mirrors/node/latest-v8.x/node-v8.9.3.tar.gz
tar -xzvf node-v8.9.3.tar.gz

(可选)解压后可以删除源代码包,释放空间

rm node-v8.9.3.tar.gz

然后进入解压后的目录

cd node-v8.9.3
./configure

。。。。。失败,gcc-c++编译器太老,升级编译器巨坑,换条路子
如果上面的命令成功,接下来执行:
编译

make
如果报错
fatal error: zlib.h: No such file or directory #include <zlib.h> 缺少
zlib的头文件, 开发包没装,
yum install zlib (系统默认已经装上)
yum install zlib-devel
解决
如果还报错 Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains:
/usr/local/lib64/ yum install perl-ExtUtils-Embed -y

安装

make install
不指定prefix,则可执行文件默认放在/usr
/local/bin,库文件默认放在/usr/local/lib,配置文件默认放在/usr/local/etc。其它的资源文件放在/usr
/local/share。你要卸载这个程序,要么在原来的make目录下用一次make
uninstall(前提是make文件指定过uninstall),要么去上述目录里面把相关的文件一个个手工删掉。
指定prefix,直接删掉一个文件夹就够了。

去官网下载二进制包:

wget https://nodejs.org/dist/v8.9.3/node-v8.9.3-linux-x64.tar.xz
xz -d node-v8.9.3-linux-x64.tar.xz
tar -xvf node-v8.9.3-linux-x64.tar
mv node-v8.9.3-linux-x64 /usr/local/nodejs

配置环境变量

vi /etc/profile

最后面添加:

export NODE_HOME=/usr/local/nodejs
export PATH=$NODE_HOME/bin:$PATH

:wq保存,然后运行

source /etc/profile

可以用node -v和npm -v来检查下:

    node -v
    // v8.9.3
    npm -v
    // 5.5.1

查看环境变量是否生效

echo $PATH

安装git

下载git

wget https://www.kernel.org/pub/software/scm/git/git-2.15.1.tar.gz

执行

$ yum install curl-devel
$ # cd to wherever the source for git is
$ cd /usr/local/src/git-1.7.9  
$ ./configure
$ make
$ make install

编译安装完以后git命令无法直接使用,需要设置下环境变量。执行如下操作:

echo "export PATH=/usr/local/git/bin:$PATH" >> /etc/profile
source  /etc/profile

好像可以通过 yum -y install epel-release 安装git和node
yum -y groupinstall "Development Tools" 
yum -y install git

如果遇到git fatal: Unable to find remote helper for ‘https’的错误,可以通过

whereis git

找出对应的git安装目录,删除,然后安装

yum install curl-devel

然后再走一遍编译安装的步骤,就能搞定啦

安装zsh

sudo yum update && sudo yum -y install zsh
chsh -s $(which zsh)
echo $SHELL

安装好需要reboot重启系统,才能生效,验证下

clipboard.png

关注公众号【好便宜】( ID:haopianyi222 ),领红包啦~
阿里云,国内最大的云服务商,注册就送数千元优惠券:https://t.cn/AiQe5A0g
腾讯云,良心云,价格优惠: https://t.cn/AieHwwKl
搬瓦工,CN2 GIA 优质线路,搭梯子、海外建站推荐: https://t.cn/AieHwfX9
扫一扫关注公众号添加购物返利助手,领红包
Comments are closed.

推荐使用阿里云服务器

超多优惠券

服务器最低一折,一年不到100!

朕已阅去看看